Tuesday, November 25, 2008

Outlook Spelling Troubleshooting

Client:
says his spell checker when doing an email in Outlook isnt catching mispelled items? any clues?


Me:
Depends on what he means:

- "It used to make the little red squiggles under a misspelled word like in Word"
- It'll only do that if Word is the e-mail editor. "Tools" -> "Options" -> "Mail Format" -> "Use Microsoft Office Word to edit e-mail messages". Note - I'm not a fan of this personally... It makes e-mail slower ;)

- "It doesn't automagically check spelling when I send the message"
- "Tools" -> "Options" -> "Spelling" -> "Always check spelling before sending"

- "It's not catching this word..."
- "Tools" -> "Options" -> "Spelling" -> "Edit" under 'Edit custom dictionary'

- "It's just flat out not working!"
- Something else is broken ;)

Labels: ,

Thursday, November 13, 2008

Linksys troubleshooting

One day I plan on writing up a quick set of instructions on how to set up a Linksys WRT54g Pro IT style. It's easy enough to set one up without needing to run their weird CD, and quite possibly leaves you in a better situation.

With the idea of documentation in mind, when a client e-mailed me this morning about their connection issue at home using the above setup, I wrote a horrendously long set of troubleshooting steps. It's really only four quick things to check, but I tried to write it fairly low-level / in-depth. Of course, it was also written pretty quick, so it's not the best of documentation, but hey -- it's a start ;)

The setup (iirc) is using the linksys as a router/gw for the client's home network.

-------

Well, I guess there's a few things you could try / check....

1st -- verify how things are plugged into the Linksys router. Make sure that there's a cable from the 'internet' port of the Linksys to the cable modem. If everything's wireless, that should be the only network cable. If your PC in your room is connected via wired, it should be plugged into one of the 4 'LAN' ports on the Linksys.


2nd -- ping a couple key things.... "Start" -> "Run" -> type 'cmd' -> "OK". In the black dos window that comes up, type "ipconfig" and hit enter. That'll give you something like:

-------------------
Windows IP Configuration
Ethernet adapter Local Area Connection:
Connection-specific DNS Suffix . : carolina.rr.com
IP Address. . . . . . . . . . . . : 192.168.5.100
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.5.1
-------------------

You may see something like "Media State . . . . . . . . . . . : Media disconnected" for one or two adapters. That's fine. As long as you see one that has a default gateway set. The "Default Gateway" in the example above is "192.168.5.1". I'd want to make sure I can ping that gw (gateway). In that same dos window, type "ping 192.168.5.1" (replacing "192.168.5.1" with whatever your gateway is). You should get four responses that look one of two ways:

Reply from 192.168.5.1: bytes=32 time<1ms TTL=64

-- or --

Request timed out.

If it's the latter, there's something wrong with the Linksys.


3rd -- Assuming you can ping the Linksys, open a web browser and in the address bar, type the gateway address from above (192.168.5.1 in the example). It should prompt you for a username and password. The username is 'admin', and if it's default, the password is either 'admin' or 'password' (I'm breaking my rule of not e-mailing passwords, but it's a default password, so crackers could just look it up if they wanted to -- and they'd have to be on your internal network to get to that management interface). If it's not the default password, try a few of yours. Once you're in (assuming we found the password), go to the "Status" page (far right on the top row of menu items). It should note the IP address, subnet mask, and default gateway that is assigned to the Linksys. Note that default gateway. That's the next address we want to ping. If you don't have an address there, either a) TW's modem's not handing out address properly, b) the cable/connection is bad between the modem and the Linksys, or c) something's not right with the Linksys (broken, cable plugged in the wrong place (see 1st suggestion), not configured for DHCP, etc).
Assuming all looks right, back in the dos window, type "ping 24.5.6.1" (replacing 24.5.6.1 with whatever the gateway was on the Linksys status page). It may be easiest to drag/move the dos window to an area of the screen such that you're able to read the Linksys page behind it. Again, take note of the ping replies. If you get "Request timed out", I may blame it on the Linksys. It may not be NAT'ing correctly or something...


4th -- Last, try pinging the DNS servers noted on the Linksys status page.

Well, that's quite the list of things to try, so -- let me know how that goes and we'll figure out more from there ;)

Mike Jolly

Labels: , , ,